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CHAPTER

ONE

GETTING STARTED

This chapter is divided into two subsections. In the first, we will
configure an email account through which SerialMailer can send the
mails. The second part will then focus on how to send a personalized
newsletter to multiple recipients.
Let’s start by opening SerialMailer via a double click on its icon in
your Applications folder.

1.1 Configuring SerialMailer
To set up SerialMailer, open its preferences through the SerialMailer
menu at the top of the screen.
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Since we haven’t set up any accounts so far, the account list is empty.
We can change this by clicking on the + menu underneath the list and
choosing Basic Email Account (smtp). This will bring up a screen
where we can either select a well known Email provider, or choose to
configure the account manually.
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If you choose one of the well known Email providers, you will only
have to enter your name, username and password. The manual configuration will first try to guess the right account settings based on your
email address and then ask you for further details in the next step.
After you completed these steps, your account will show up in the
accounts list and is ready to be used for sending your first email with
SerialMailer.

1.1. Configuring SerialMailer
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1.2 Your First Newsletter
After opening SerialMailer, the first window you see is the Database
Manager. It presents you with all your recipient lists, including those
found in the Contacts application (if not, make sure to give SerialMailer permission to access it).

1.2.1 Creating a new email
The quickest way to start a new email is to select one of the lists and
press the New Mail button at the top. This will create a new Email
with a copy of all the recipients in the selected list.
If you don’t have a list ready, you can press the New Mail button
without selecting a list. This will create an empty mail document,
where you can fill in the recipients manually.
4
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Use the + and - buttons at the top to create new entries in the recipient
list.
Each column represents one field that can later be inserted into the
message. The name of the field is shown in the header of each column.

1.2.2 Editing the message
Once your recipient list is ready, you can move on to the Message
section where you can compose the email message.

1.2. Your First Newsletter
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At the top, you see the Insert Field and Insert Special Fields menus
through which you can insert fields from the recipients list into the
subject line as well as the main message body.
In the To menu, you can select which column to use for the recipient’s email address. You can also choose Multiple and enter a comma
separated list of addresses (including fields).
To make use of text formatting (images, different fonts, . . . ), make
sure that Formatted Text is selected from the Format menu below the
subject line. You can then enter a text like the one below.
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Click on an image in the editor to see further formatting options. You
can also use the Format menu from the main menu bar at the top,
which gives additional options like inserting lists.

1.2.3 Preview the mail
Since this is a quick start guide, let’s skip the Attachments section and
go straight to the preview.

1.2. Your First Newsletter
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Here you can make sure that the final message looks as expected. Use
the < and > buttons at the top to switch between the recipients.

1.2.4 Send
Once you are happy with everything, you can send your mail by pressing the Send button at the top of the window. This will open the Send
Window where you can select which email account to use and if a
copy of each mail should be sent to a common address (BCC).
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Since we only configured one account, you can just press the Send
button and SerialMailer will start creating and sending the mails for
each recipient.
The log will show a note for each mail that was sent successfully.
Make sure to save your email through the File > Save menu if you
want to access the recipient list or the log at a later time.

1.2. Your First Newsletter
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CHAPTER

TWO

DATABASE MANAGER

One way to organize your address lists is to use the Database Manager that comes with SerialMailer. It presents you with all your recipient lists, including those found in the Contacts application (if not,
make sure to give SerialMailer permission to access it).
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2.1 Data Sources
You can use the Database Manager to access recipient lists from different sources:
Contacts Here you find the contacts stored in the Contacts Application. They can not be edited in SerialMailer.
SerialMailer Database This is the internal database of SerialMailer.
Here you can create your own recipient lists with custom fields.
They will only be accessible from within SerialMailer.
Remote SerialMailer can download address lists from remote
sources. Be aware that all edits to addresses in these lists are
temporary and will be overwritten once a new version is downloaded from your web server.
To rename a list, double-click on its name. To add a new list, press
the + button and choose either Local (to store it in the SerialMailer
Database), or Remote.
Use the Options menu below the recipient list to change the
field/column names.

2.1.1 Remote Lists
Remote address lists allow you to download a list of addresses from a
remote web server and automatically import it into SerialMailer. This
can either be a static file, or it can be generated on the fly using a
script running on the server (e.g. to access a MySQL database).
To secure the list, you can also make use of http authentication.
SerialMailer will then request the password from you when needed.
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To update a remote list, select it and press the Download button in the
lower right of the window.
The format of the list should be that of a CSV (comma separated
value) file. A very basic version of it could look like this:
EMail, Name
peter@example.com, Peter
jessica@example.net, Jessica

Note that the first line is interpreted as the field names.

2.1. Data Sources
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2.2 Import / Export
SerialMailer can import and export various files as recipient lists,
among those are:
CSV/Text A basic text format that can be exported by most spreadsheet applications
Excel (xlsx) Excel tables. SerialMailer only supports the newer xlsx
format, which was introduced with Excel 2007.
SerialMailer file Imports the recipient list of a SerialMailer Message
document.
The Import/Export commands are available from the File menu.
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CHAPTER

THREE

EMAIL DOCUMENT

Each Email composed in SerialMailer is a separate document that
contains the recipient list as well as the message text and attachments.
To create a new mail, choose either New from the File menu, or press
the New Mail button in the Database Manager.
The document window has multiple sections with the Recipients list,
Message, Attachments, Preview and Log.

3.1 Recipients
The Recipients section lists the addresses to which the mail will be
sent.
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You can add lists from the Database Manager by dragging them from
its source list to the recipient list in the mail document.
Addresses can be enabled and disabled using the checkbox in the second column. Use the filter commands above the list to change the
state of multiple entries at once.
The Last Sent column lists the date on which the mail was sent to that
recipient.
The list can be sorted by double-clicking on one of the column headers.

3.2 Message Editor
In the message editor, you specify the recipient of the mail, edit the
subject and the main email text. You can also insert placeholders for
fields from the recipient list to personalize the message.
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3.2.1 Recipient Address
In the To menu, you can set which of the columns in the recipient list
is used as the email address the mail is sent to.
As an additional option, you can choose Multiple. . . . This will reveal
a text field where you can enter a comma separated list of addresses.
These addresses can also be built out of fields/columns from the recipient list. To insert a field, use the Insert Field menu, just as you do
when inserting fields into the message.
Just like the main recipient, you can add CC (Carbon Copy) addresses
using the CC menu. If this is not needed, you can leave the CC menu
on its default setting None.
Caution: When using Multiple. . . , it is important to make sure
that the email addresses are separated by a comma. Just inserting

3.2. Message Editor
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multiple fields after one another would concatenate the addresses,
forming an incorrect and malformed email address.

3.2.2 Personalization
To insert a field/column from the recipient list, insert a field in the
subject line or the message body using the Insert Field menu at the
top.
More complex fields are available from the Special Fields menu.

3.2.3 Smart Field
A Smart Field can be inserted via the Special Fields menu. It changes
its text depending on the content of other fields. The conditions are
tested in the order in which they are found in the list and once a condition is true, its contents will be inserted and all other conditions
ignored.
An ‘else’ case, which should be used if non of the other conditions
are met, is not available. However, you can add a condition which
will always be true at the end of the list as a workaround. This could
be something like ‘If the field name is not xyzabcnoname’.
You could use ‘smart fields’ to automatically adjust the greeting line
to the gender of the recipient:
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The field can be edited by clicking on its placeholder box in the message view.

3.2.4 Formatting Options
Plain Text This is the most basic option. You cannot insert images
or change the font style. It is most compatible with all Email
clients available.
Formatted Text With this option, you can format your message. You
can insert images, tables, lists and links.
Template You can use a design template / stationary. The editor will
behave the same way as when using formatted text, but the preview will show that your text is embedded in a more complex
design.
You can create your own design templates based on html pages
and install them in SerialMailer’s preferences.

3.2. Message Editor
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Treat Text as HTML-Code This mode is most suited for experts.
You can create and import raw html pages. To insert images
use the HTML Embedded File from the Special Fields menu.
This field will take care of attaching the given file and creating
a file path / url that points to the attachment.
An image tag in the html code would then look like this:
<img src="[HTML Embedded File]">

You can use the buttons at the top to switch between the plain
text and the html version of the email.

3.2.5 Importing HTML
SerialMailer can import a html document (webpage) into the editor.
This will not only place the code into the editor and switch to Treat
Text as HTML-Code mode, but also try to resolve and attach all resources/images used in the page.
Since SerialMailer needs access to all associated files, you have to select the folder that contains the html page and all its resources, rather
than just the html page itself. Once this is done, a window opens
that allows you to select the page’s text encoding and that shows all
resources detected in the html.
If a resource was not found, you can press the Select File button to
select a file manually.

3.3 Attachments
As with any normal e-mail client, you can add attachments to your
mail. SerialMailer, however, not only supports plain files that are
attached to every mail, but also personalized attachments. With personalized attachments, the attached files can change depending on the
recipient.
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To add a normal file, choose Plain File from the + menu at the top.
You can also add a Personalized attachment:

All of the files that will possibly be attached as this personalized attachment have to be stored in one folder. This folder is the Root Folder
which can be set using the Set button.
The file that is chosen from within the root folder is the one with the
name specified in the File Name text field. To personalize the attached
file, the file name may contain fields from the recipient list, just like
the subject and body of the mail message. These fields can be inserted
with the Insert Field menu.

3.3. Attachments
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3.4 Sending the mails
Once you added all recipients to the database and composed your
message, you can send the mails by pressing the Send button at the top
of the document window. This opens a window with several options.

E-Mail Account menu Select the mail account which SerialMailer
should use to send the mails.
BCC field You can enter a comma separated list of email addresses
that will receive a copy of every mail sent. Especially useful if
you would like to receive a copy of every mail at your own mail
address to keep track of the mails sent.
Send to menu You can specify a list of test addresses (taken from
the SerialMailer Database in the Database Manager) or simulate sending as a dry-run. When Recipient List is selected, the
mail will be sent to the actual recipients in the list of the mail
document.
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Press the Send button to send the mails. This will also open a progress
window. You can abort the send process in two stages using the Cancel button. If you only press it once, SerialMailer will stop after the
current mail has been dispatched. The program will stop immediately
after a second click.

3.4. Sending the mails
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CHAPTER

FOUR

PREFERENCES

4.1 Email Accounts
SerialMailer supports multiple account types which will be described
in the following sections. In most cases, Basic Email Account (smtp)
– which makes SerialMailer behave like an ordinary e-mail client – is
the best option.
All of these account types are added through the + menu under the
account list.
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4.1.1 Basic Email Account (smtp)
This is the most versatile account type making SerialMailer act like a
normal email client. Imported accounts from Apple Mail will also be
of this type.
When you add a basic account, you will first see a screen where we
can either select a well known email provider, or choose to configure
the account manually.
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If you choose one of the well known Email providers, you will only
have to enter your name, username and password. The manual configuration will first try to guess the right account settings based on your
email address and then ask you for further details in the next step.
After you completed these steps, your account will show up in the
accounts list and is ready to be used for sending your first email with
SerialMailer.

4.1. Email Accounts
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4.1.2 Apple Mail Account
With this account type, SerialMailer will not send the mails by itself.
Instead, it will remotely control the standard Mail app from Apple to
send the mails. While this account is very easy to set up, it comes
with several limitations, as SerialMailer does not have full control
over how Apple Mail sends the messages. The most notable one is
that you can send only plain text messages.

4.1.3 Local Server
When using a local server, no external mail server is required and
SerialMailer will send the messages directly to the recipients. Any
email address can be entered as the sender address.
Caution: Depending on your internet connection, this send
method might not work and cause a majority of the mails to be
rejected by the recipients. The reason for this is that most major
mail servers are only accepting mails from well known and trusted
internet addresses. If you get a lot of errors while sending, you’ll
have to use a different account type.

4.2 Templates
You can install and remove custom design templates under the Templates tab. To install a template, press the Add Template button and
select the folder containing the template files.
The structure of the template folder is basically a website with a central index.html, which contains the text [[[message]]]. This text
will then be replaced by the text of your email message.
A typical template folder looks like this:
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4.3 Blacklist
The blacklist is a global list of e-mail addresses to which SerialMailer
will send no e-mails. The addresses can either be added manually, or
by importing a file that contains one address per line.
You can use * as a wildcard character to block multiple addresses at
once. For example *@mail.com would block all addresses ending
in @mail.com.

4.3. Blacklist
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4.4 SerialMailer Settings

If the Ignore . . . errors option is enabled, SerialMailer will not cancel
the send process immediately as an error occurs. This can be helpful
if you know that some of the e-mail addresses in your database might
be outdated and you want SerialMailer to continue sending even if
some of the mails can’t be delivered.
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CHAPTER

FIVE

ACCOUNT SETUP EXAMPLES

5.1 Google GMail
This section describes how to setup SerialMailer on your mac to send
mass mails through your Google GMail account.
Open the “Preferences” through the “SerialMailer” menu.

Go to the “Accounts” section.
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Select “Basic Email Account (smtp)” from the plus menu below the
accounts list.

A window will open where you can select presets for some email
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providers, or use a custom configuration. Choose “Google Mail /
GMail”.

Enter your name and email address in the next window.

5.1. Google GMail
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SerialMailer will add and automatically configure your account. You
can now close the preferences window and send your personalized
email campaign.
The first time you use this account, SerialMailer will open a window
with the gmail login, asking you to sign into your google account and
granting SerialMailer access to send mails.
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5.2 Microsoft Office365
This section describes how to setup SerialMailer on your mac to send
bulk mails through your Microsoft Office365 email account.
Open the “Preferences” through the “SerialMailer” menu.

Go to the “Accounts” section.

5.2. Microsoft Office365
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Select “Basic Email Account (smtp)” from the plus menu below the
accounts list.

A window will open where you can select presets for some email
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providers, or use a custom configuration. Choose “Microsoft Office365”.

Enter your name and email address in the next window.

5.2. Microsoft Office365
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SerialMailer will add and automatically configure your account. You
can now close the preferences window and send your email campaign.

5.2.1 Two-Factor Authentication
By default, SerialMailer will add an account that supports two-factor
authentication. The first time you send mails using your Office365
account, SerialMailer will open a window with a login website provided by microsoft. Here, you can grant SerialMailer access to your
account.
Some business accounts might require your administrator to allow
you to use SerialMailer with your Microsoft account.
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If you want to use the classic methods to login based on a username
and password stored in SerialMailer, you can disable the OAuth /
two-factor login by going to the “Advanced” part of the account preferences and disabling the “Use OAuth” setting. Usually this is not
required.

5.2. Microsoft Office365
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